https://blog.csdn.net/u010837612/article/details/89210150

IDEA升级到2019.1版本,发现lombok插件提示不兼容。

解决方法:

用压缩工具打开用户目录下 .IdeaC2019.1->config->plugins->lombok-plugin/lib/lombok-plugin-xxxx.jar ,编辑META-INF/plugin.xml 文件第6行,将idea-version改成你当前idea版本号:

如:

  <version>0.29-2020.1</version>
  <idea-version since-build="201.6668.121" until-build="201.*"/>

查看IDEA版本号方法:点击Help->About